Skip to main content.

I enjoy using and contributing to NetBSD. My online journal has documented a small part of my NetBSD experiences.

Some NetBSD developer photos are here.

My NetBSD Questions (or Infrequently Asked Questions)

If you have any answers or pointers to documentation for these, please, please, let me know.

1. bit torrent really available? (anyone participate to make it worthwhile?)

2. Why does boot menu show "Fn" when it is not a function key?

3. What is not included with NetBSD's GCC installation? Just Java and Fortan excluded or other common stuff?

4. What does it mean in sysinst about wrong geometry for disk? When does it matter? is the default color output from kernel green and userland white on all platforms by default?

5. How to know how to "Set the geometry by hand" in sysinst? Any guide for this?

6. any examples of doing snapshots using fss?

7. how does fss compare with HAMMER?

(fss is for snapshots. HAMMER provides continuous snapshots. I know they are very different, but I am wondering how they are similar. I think fss is a NetBSD feature that is not well publicised.)

8. will pkg_add check the availability of ALL dependency binary packages before installing any? If not, how do you handle this?

9. Examples for /altroot ?

I was told: "./build.sh install=/altroot/" /altroot directory exists on my systems. I want to know why and hier(7) doesn't tell me much. This example above makes sense -- I wonder where that should be documented.

10. Examples for /stand ?

Empty /stand also existed on my system. hier(7) tells little. I guess someone used this for something before, but can't find docs to know why or how to use in the future.

11. Examples for /targetroot ? (As far as I can tell, it is leftover from sysinst. Ever used after installation?)

12. what is the reverse of usermod -G (i.e how to remove a user from a group)?

13. how to get wsconscfg to display the current emulation (like set with -e)?

14. Any platforms not support virtual terminals? (does no WSDISPLAY_COMPAT_USL option mean it has no Virtual terminal support?)

15. login.conf manpage says login-backoff is random, but really is: sleep((u_int)((cnt - login_backoff) * 5)); What should it be?

16. login uses execlp to start user's shell, so why do I still have login running (it is the parent of my shell instead of init)?

17. /etc/rc.d/fsck could reboot system is ran later (after boot) -- is that okay?

18. savecore man page says ran before swapping is enabled; but rc.d script is ordered to run long after swap is up. Will the snapshot be lost?

(This is a bug, I can't remember if I reported and if fixed yet.)

19. what is purpose of top of etc/rc.d/wscons wscons_start with the $# options? what uses that? any examples? does not seem normal for an rc.d script

20. shouldn't all rc.conf scripts have an rcvar enable variable?

21. shouldn't all rc.conf.d/ config file name match the rc.d script name?

22. what uses the "umask" login.conf capability?

I think I will improve login.conf.5 so it is more clear that some settings are for login(1) itself and others are for the user's environment. (And maybe note that need to re-login, even though that is probably obvious.)

23. kernel says clock lost days and "WARNING: using filesystem time" -- what does that mean?

24. Does sysinst detect other MBR partitions to choose to ask if to install a bootselector or not?

25. Does the sysinstall MBR partition flag for "install" even used? (seems to work with yes or no)

26. Where is the documentation or explanation for "bootmenu" and "default" in the sysinst MBR editor?

27. Any docs for Extended partitions in MBR partition editor in sysinst?

28. Why does sysinst default to mfs instead of tmpfs for /tmp in new install?

29. Why no wapbl in sysinst?

30. Does sysinst offer ccd and/or raid support for /? Where document?

31. What is the purpose of naming a disk? Where is "packid" or bsddiskname" documented?

32. On some ports, why does NOT sysinst install bootstrap or bootloader?

33. Where is set skip, set skip group, and Abandon in sysinst sets retrieval documented? What is a "set skip group"?

34. What does "manual" as default media type for an network interface mean? (most default to "autoselect")

35. What files are backed up on sysinst upgrade -- I only see /etc/passwd.conf.pre-sysinst what else? I don't see fstab backed up.

36. How to print the current wsconscfg settings? For example, you can define a screen type and emulation -- how to report the current type or emulation?

37. hpcarm, hpcmips, hpcsh, sparc, and sparc64 kernels define the WSDISPLAY_DEFAULTSCREENS option. But I don't see vga -- so do they really have virtual terminals? Where is this documented?

38. What is the purpose of ttyE0 versus console in /etc/ttys? Why some platforms have console on and ttyE0 off and others have ttyE0 on and console off? Why would someone enable ttyE0? Why do some ports have ttyE0 enabled and console off? And why some only turned on via sysinst?

39. Why would someone enable constty in ttys(5)?

40. What defines powerd "normal" state?

41. Why does envstat output in proplist XML but config is in entirely different format (like dhcp style)?

42. Any examples of hardware (or ports) not supporting powerd events (like may not recognize when power button is pushed)?

43. Any way to configure envsys alarms in NetBSD 4.0?

44. Any examples of hardware or ports that don't have envsys support (no envsys drivers)?

45. Why doesn't kernel/dmesg indicate a device there is a "envsys" device?

46. What does critical-capacity and warning-capacity mean for "temperature" (anything?)?

(Maybe envstat output should say "NA" where it is not applicable?)

47. How to know if some property can't be set? (not a tunable?)

48. Any purpose to envsys=YES but keep powerd=NO?

49. Are any temperature or other sensor limits ever predefined at boot time by the kernel (not envsys.conf)? If so, any examples?

50. What does "active cooling level 1: 41.8C" mean in "acpitz0 at acpi0 (TZCR): active cooling level 1: 41.8C critical 102.0C"?

51. What does "passive 66.0C, passive cooling" mean in "acpitz0 at acpi0 (THRM): critical 105.0C passive 66.0C, passive cooling"?

52. Is the term "critical" overloaded? As in dmesg output it refers to the temp where it powers off, but "critical" in envsys.conf and powerd, the system is obviously still running.

53. What is modern/recent purpose of the daemon user?

54. What is modern/recent purpose of the operator user (not group)?

55. What is modern/recent purpose of the bin user (other than third-party software)?

56. What is modern/recent purpose of the sys group?

57. What is modern/recent purpose of the daemon group other than LPR/LPD?

58. What is modern/recent purpose of the staff group and guest group in the default install?

59. Why does NetBSD have both nobody group and nogroup group?

60. What is modern/recent purpose of the mail group in default install?

61. Where is /etc/powerd/actions/ documented?

62. How to utilize powerd "hotkeys"? Any examples?

Please share any answers or documentation pointers for my questions. Thanks