Skip to main content.

2002-Feb-13

Added a new drive. Current disk:
$ BLOCKSIZE=`expr 1024 * 1024` df
Filesystem  1048576-blocks     Used    Avail Capacity  Mounted on
/dev/wd0a              112       64       43    59%    /
/dev/wd0e             1195     1120       15    98%    /usr
/dev/wd0f             1494     1144      274    80%    /usr/src
/dev/wd0g             1498     1374       49    96%    /home
/dev/wd0h             1494      852      567    60%    /usr/pkg
kernfs                   0        0        0   100%    /kern

Changed sysid from 131 (Linux) to 169 (NetBSD). For some reason, this seemed to remove my wd1a and unconfigure my wd1f partitions. (It had FreeBSD on it.) Used sysinst to partition and newfs wd1. * Where is this interactive tool other than sysinst? It also installed a "boot" file which I deleted.

During a "cp -PRp /usr/local/ /mnt":

$ iostat -w 5 -c 5 wd0 wd1
tty            wd0             wd1             cpu
tin tout  KB/t t/s MB/s   KB/t t/s MB/s  us ni sy in id
5   81 13.15   1 0.02   9.03   6 0.05   0  0  0  0 100
0   35  4.59  38 0.17   4.12 110 0.44   0  0  3  0 97
41   24  5.03  44 0.21   4.11 100 0.40   1  0  3  1 96
15   16  9.53  76 0.71   6.27 174 1.07   1  0  3  2 94
9   14  5.79  57 0.32   5.68 105 0.58   0  0  3  1 96
$ iostat -D -w 5 -c 5 wd0 wd1
wd0            wd1
KB xfr time    KB xfr time
38   3 0.02    77   8 0.03
371  64 0.24   608 111 0.74
172  57 0.19   661 116 0.78
223  44 0.19   601 109 0.83
217  40 0.35   511 102 0.77
When copying over /usr/pkg at same time:
$ iostat -w 5 -c 5 wd0 wd1
tty            wd0             wd1             cpu
tin tout  KB/t t/s MB/s   KB/t t/s MB/s  us ni sy in id
5   79 11.03   6 0.06   7.99  14 0.11   0  0  0  0 99
12   35  4.21  15 0.06   6.25  81 0.50   0  0  2  0 98
5   12  3.54  22 0.08   6.22 143 0.87   0  0  2  1 97
0   12  2.81  24 0.07   4.90  52 0.25   0  0  1  1 98
31   12  3.67  29 0.10   5.13  56 0.28   0  0  2  1 97
$ iostat -D -w 5 -c 5 wd0 wd1
wd0            wd1
KB xfr time    KB xfr time
61   5 0.03   111  14 0.07
438  41 0.27   682  86 0.99
301  30 0.19   519  80 0.99
53  17 0.11   278  53 1.00
113  22 0.23   545  94 1.00

I unmounted /usr/pkg and some shells hung (probably using libraries, because fstat didn't indicate use). Couldn't open xterm (from blackbox menu) because no /usr/pkg/bin/bash. (So later I made xterm use sh(1).) I logged on remotely and mounted new /usr/pkg partition.

Under /usr/src I did a "time cvs update | tee LOG". My CVS/Tag file already contained "Tnetbsd-1-5". (This as done as non-root.) After 13 minutes, it reported:

cvs [server aborted]: cannot open directory /cvsroot/basesrc/dist/am-utils/aux: No such file or directory
I had heard about this problem before, but I thought only applied to -current. So I manualled deleted that directory and removed the reference to it in dist/am-utils/CVS/Entries. And did "time cvs update 2>&1 | tee LOG2" again. Had to start again: "time cvs update 2>&1 | tee LOG3" (see above about umounting /usr/pkg).

Later, my gui seem to hang (I could still move mouse, but pointer was orange and a text cursor from previous rxvt). I logged in remotely and saw several bashs and rxvts were running out of control, so I killed them (SIGKILLs were needed for the bash). Strangely, my rm and cvs jobs continued -- the parent became init.

I enabled USB in my BIOS. My kernel reported:

uhci0 at pci0 dev 7 function 2: VIA Technologies VT83C572 USB Controller (rev. 0x02)
uhci0: interrupting at irq 10
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: VIA Technologie UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered

And a kernel thread for usb was running:

root   2  0.0 10.9    0 14260 ?? DL    1:21PM 0:00.01 (usb0)
Then I plugged in a SanDisk:
Feb 13 16:54:15 rainier /netbsd: uhub0: port error, restarting port 1
Feb 13 16:54:17 rainier /netbsd: umass0 at uhub0 port 1 configuration 1 interface 0
Feb 13 16:54:17 rainier /netbsd: umass0: SanDisk Corporation ImageMate CompactFlash USB, rev 1.10/0.09, addr 2
Feb 13 16:54:17 rainier /netbsd: umass0: using SCSI over BBB-P
Feb 13 16:54:17 rainier /netbsd: scsibus at umass0 not configured
From looking at some example from the current-users mailing list archive, I see that it should attach to some type of disk. So for my kernel configuration, I uncommented:
sd*     at scsibus? target ? lun ?      # SCSI disk drives
scsibus* at umass? channel ?
(Will build once above "cvs update" is finished downloading.)

The cvs seems to be done transferring, but it still runs and network connection is still up (FIN_WAIT_2). I have a few files that were modified or conflicted during the CVS update:

$ grep '^[CM] ' /usr/src/LOG3
M bin/cp/utils.c
M bin/ksh/eval.c
M bin/sh/expand.c
M bin/sh/expand.h
M distrib/i386/floppies/Makefile
M distrib/i386/floppies/fdset-common/Makefile.inc
M distrib/i386/floppies/ramdisk-small/Makefile
M distrib/i386/floppies/ramdisk-small/list
C distrib/i386/floppies/ram.disk-tiny/list
M distrib/notes/Makefile.inc
M gnu/usr.bin/gzip/Makefile
M lib/libc/gen/__glob13.c
C lib/libc/time/localtime.c
M libexec/ftpd/ftpd.8
M libexec/ftpd/ftpd.c
M usr.bin/id/id.c
M usr.bin/telnet/commands.c
M usr.bin/telnet/main.c
M usr.bin/tn3270/Makefile.inc
M usr.bin/who/who.c
C usr.sbin/catman/catman.c
M usr.sbin/lpr/lpd/printjob.c
The "modified" means that no newer version was available or it was merged successfully. A "conflict" means it was not merged very well (see 01/June/2001). the files updated were:
distrib/i386/floppies/Makefile
distrib/i386/floppies/ramdisk-small/Makefile
distrib/i386/floppies/ramdisk-tiny/list
lib/libc/time/localtime.c
usr.sbin/catman/catman.c

I want to use official netbsd-1-5 code, so I need to either remove these files or back them up. I just copied them all (with same directory hierarchy) with:

grep '^[CM] ' /usr/src/LOG3 | cut -c 3- | cpio -pdm /home/reed/netbsd/my-changes/
Then I removed them:
rm -f `grep '^[CM] ' /usr/src/LOG3 | cut -c 3-`

Well the cvs has been done but still running for over an hour. Now that I deleted the above files, I need to fetch again (at 19:09):

time cvs update 2>&1 | tee LOG4
Moments later I killed the first cvs process.

I also copied over the originals before the conflicts with:

find `grep '^[C] ' /usr/src/LOG3 | cut -c 3- | xargs -n 1 dirname` -name ".#*" | cpio -pdm /home/reed/netbsd/my-changes/

I am keeping these files (at least temporarily) so I can compare with official. I may need to follow-up on some of these (maybe PRs). (See 18/Jan/2001, 16/Mar/2001, 25/Apr/2001, 10/Apr/2001, 04/May/2001.)

As I looked through the "?" files (in my directory but not in source repository), I saw a cvs core dump from today (I deleted it). I see I have several files to delete (some are compile/object files that should be elsewhere).

The cvs update has been done for probably a couple hours, but netstat still shows "FIN_WAIT_2" (to cvs server). So still waiting for server to respond saying it will send no more data.